Breadcrumbs

Noise on Comm with Bendix King 97A Radio

More
04 Aug 2020 20:08 #1 by George Polos
Replied by George Polos on topic Noise on Comm with Bendix King 97A Radio
Thanks Matt. I'll check out the shop in Utah. Not many avionics shops want to deal with repairs.

Please Log in or Create an account to join the conversation.

More
04 Aug 2020 15:03 #2 by Matt Gunsch
Replied by Matt Gunsch on topic Noise on Comm with Bendix King 97A Radio
I had a number of problems with the 97A in my coupe, it was showing that it was transmitting, but nothing was going out. I found a shop in Utah that cleaned it up, replaced a number of capacitors and transistors and it works great now. You might also check the grounding of your antenna and coax cables, without a good ground plain the antenna can't work it's best.

A&P, IA, PPSEL
too many years GA and Warbird Maint
Check out the Ercoupe Discussion group on facebook

Please Log in or Create an account to join the conversation.

More
26 Jul 2020 21:37 #3 by Ronald Raty
Replied by Ronald Raty on topic Noise on Comm with Bendix King 97A Radio
WD40 leaves a residue. For electrical contacts, stop by your local automotive store and ask for a spray can of electrical contact cleaner.
The following user(s) said Thank You: George Polos

Please Log in or Create an account to join the conversation.

More
26 Jul 2020 14:22 #4 by George Polos
Noise on Comm with Bendix King 97A Radio was created by George Polos
I have a Bendix King 97A Radio in my 415-C. Receiving transmissions nearby is usually clear but often (not always) distant transmissions from ATC and other aircraft is full of noise and hard to understand. Squelch control does not help.

I have removed the radio several times to clean the contacts (using WD40) and that seems to help initially but not for long.

I am wondering if I should try to replace the radio with another 97A (used) or if the problem could be coming from wiring or the antenna.

Any advice? Thanks.

Please Log in or Create an account to join the conversation.

Time to create page: 0.134 seconds
Powered by Kunena Forum